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Introduction

This tutorial  guide was developed to cover the functions of Fast 
Specificator v.3.0.1. Fast Specificator is an application for 2D claddings 
and specifications. It is designed to run under AutoCAD environment for 
increased  compatibility  with  drawings  provided  by  the  client.  This 
application  is  capable  of  functioning  with  any  drawing  supported  by 
AutoCAD that meets certain requirements, presented further.

Chapter 1. Installation and authentication

To  install  Fast  Specificator  you  must  have  a  working  copy  of 
AutoCAD in your computer. Fast Specificator’s compatibility covers all 
versions  of  AutoCAD  starting  with  AutoCAD  2000.  Since  Fast 
Specificator  works  with  two dimensional  drawings  only,  it  will  work 
correctly with limited versions of AutoCAD as well.

Installation of the application begins with extracting data from the 
provided archive to your computer. Since the program will always run 
from the location it is installed to, it  is better to place it in a separate 
folder. Once the folder is placed in the desired location, the installation 
continues by running AutoCAD. Note: if you are using Windows Vista, it  
is required to run AutoCAD in administration mode (it is done by right  
clicking on AutoCAD icon and selecting “Run as administrator”. In the 
main window of AutoCAD select File → Open (or Ctrl+O shortcut) and 
open file "Fast-Specificator-setup.dwg" in the installation directory (Fig. 
1).

Fig. 1. Installing Fast Specificator



Once the file is opened select Tools → AutoLISP → Load and load 
"Fast-Specificator-setup.vlx" (Fig. 2)

Fig. 2. Installing Fast Specificator 2

After following these steps the application is installed.  To avoid 
third party usage of this application, it is protected by an authentication 
system.  To  run  this  application  you  need  to  identify  yourself  to  the 
developer of the application. Once you have provided the information, 
received  the  confirmation  file  and  placed  it  in  certain  directory,  your 
copy of Fast Specificator is fully functional.

To identify yourself click on any button of Fast Specificator. Once 
you have clicked, a message pops up as in fig. 3.

Fig. 3. AutoCAD Message

Pressing the “OK” button will take you to the registration form that 
has to be filled correctly. (Fig. 4)



Fig. 4. Fast Specificator license request form

After filling the form and clicking “OK” you will be taken to your 
default  e-mail  client  window,  where  you  will  be  asked  to  attach  the 
newly  created  registration  file  “order_XXXX-XXXX-XXXX.dat"  and 
send it to the predefined address. (Fig. 5)

Fig. 5. Fast Specificator license request e-mail



Once your identity is approved you will receive an e-mail with a 
license  file  "Fast-Specificator_XXXX-XXXX-XXXX.vlx"  attached. 
Save this file in Fast  Specificator’s  \reg directory.  After saving restart 
AutoCAD.

Now Fast Specificator is installed and fully functional.

Chapter 2. Preparing the drawing

Fast Specificator application only functions correctly if the drawing 
that has to be processed meets the following requirements:

a) drawings have to be provided in AutoCAD dwg format;
b) drawings units have to be millimeters;
c) cladding areas must be predefined as closed contours;
d) elevations must be predefined as closed contours;
e) openings  (windows,  doors)  must  be  predefined  as  closed 

contours;
f) building axes must be predefined as lines;
g) possible cladding orientation : vertical / horizontal

Therefore  if  the  provided  drawing  is  finished  in  non-complex 
objects (e.g. lines) it has to be modified for Fast Specificator. There are 
several methods to achieve it.

Joining separate lines into a polyline

First method is joining separate lines into a closed polyline. It is 
relatively  fast  and simple,  but  it  changes  the  structure  of  the  original 
drawing. So there is a possibility that it will not be possible to modify the 
drawing by other programs in the next steps of development. 

To join separate lines into one closed polyline a command “pedit” 
has to be entered in the AutoCAD command line and press the  Enter 
button (Fig. 6).



Fig. 6. Making a closed polyline of separate lines

After  taking  this  action  the  program  requires  you  to  select  a 
polyline to start from. Every separate line is considered a simple polyline. 
Using a mouse select whichever line you like that includes in the closed 
contour that you need to clad and press Enter. If the program claims that 
object selected is not a polyline and asks if you want to turn it in to one 
press Y and Enter again. After that the program gives options of polyline 
editing (Fig. 7).

Fig. 7. Polyline editing options in AutoCAD command window

In the command field enter  Join and press  Enter.  The command 
line asks to select source object.  Click any line of the closed contour. 
Then the program asks to select objects to be joined to source. Click each 
and every line that forms a closed contour (Fig 7).  Note: all the lines  
have to be connected together and form a closed contour.



Fig. 7. Making a closed polyline of separate lines 2

When all the lines are selected press Enter. From now on the lines 
are considered as one closed contour polyline.

Adding a new layer with polylines

The second method is less effective to the original drawing, as a 
new  special  layer  is  created  on  the  top  of  the  drawing  without  any 
intervention to the original one. 

To fulfill this method first create a new layer in the drawing. To 
create a new layer, go to Format → Layer, or click the red marked button 
in Fig. 8.

Fig. 8. Layer Properties Manager button

The Layer Properties Manager is loaded, where you have to press 
the New Layer button (Fig. 9) or use the Alt+N shortcut. Name the layer 
with  a  name of  your  choice.  For  easier  usage  of  your  layer  you can 



customize it by changing the color, line type, or line weight. It can be 
done by clicking on these options

Fig. 9. Creating a new layer in AutoCAD

Once  the  layer  is  created  click  OK  in  the  Layer  Properties 
Manager. In the main AutoCAD window select your layer (Fig 10).

Fig. 10. Selecting a new layer

Turn the  Object Snap ON. The button is located at the bottom of 
the window (Fig. 11). 

Fig 11. Object Snap ON

Select  Draw → Polyline. Follow the original contour with a new 
line until it is complete and closed (Fig. 12).



Fig. 12. Drawing a closed contour polyline

Modifying round objects for Fast Specificator processing

Fast  Specificator  application  needs  a  base  line  and  a  corner  to 
define the beginning of cladding, so it is not possible to clad or do an 
opening when there is a round object or an ellipse.

To solve this you have to follow the method above: create a new 
layer and select a polyline. Then you have to set Object Snap to OFF and 
redraw the current round shape object in many straight lines as close as 
possible (Fig. 13).

Fig. 13. Coping with round objects in Fast Specificator



Chapter 3. Selecting and laying out the profiles

In order to know the exact button that is being described later in 
this tutorial,  an index for all available buttons is presented in Fig. 14. 
From now on every time a button is described by number it will be based 
on this figure. The buttons needed to achieve results of each chapter will 
be presented separately in the beginning of every chapter.

Fig. 14 Index of Fast Specificator buttons

To  start  working  using  Fast  Specificator  you  must  have  a  proper 
drawing  (described  in  chapter  2)  loaded  in  AutoCAD  (Fig  15).  Once  the 
drawing is loaded press the 16th button and enter the initial data of the drawing. 
It opens in a text editor. Do not edit any lines that are closed in square brackets. 
You may adjust the length rounding value in  mm. Minimal length in  mm is a 
parameter that sets the minimal length of a profile. If there is a space shorter 
than this length, the application will not add a profile there. You may change 
the  names  of  complex,  object,  customer  and  drawer  and  add  drawing 
description. If this data is entered, it will be presented later in the information 
box of the drawing frame (see chapter 8).

After setting up the initial settings click the 1st button. It will load the 
profile database to select your product from (Fig. 16).

Fig. 15. A proper AutoCAD drawing of a façade for Fast Specificator



Fig. 16. Profile selection

In this window you can select a profile you will be using for certain 
area.  You can choose between Façade and Roofing cladding type and 
Sandwich panel, Trapezoidal profile, Waveform profile, Cassette profile 
and Façade panel elements.

Once  these  selections  are  made  profile  database  presents  you 
profiles matching these criteria. When you pick a profile from database it 
previews the profile under the cladding type selection menu.

The  color  can  be  selected  from  RAL  (color  space  created  by 
Reichsausschuß für  Lieferbedingungen)  and  other  colors.  Coating  and 
thickness choices are available for every type that is being produced, as 
for width is automatically set by the program. Slope against and along 
profile will treat  the marked area as a horizontal  projection of surface 
with an incline. After configuring all the parameters click ACCEPT. 

2nd and  3rd buttons  define  if  the  profiles  are  to  be  installed 
horizontally  or  vertically.  2nd button  is  for  vertical  and  3rd is  for 
horizontal. Press the button of your choice. The program command line 
asks to select façade contour. Click on the border of a closed contour. 
Once clicked the program asks to select the alignment point, from which 
the program should start to clad the profiles. It is highly recommended to 
do that with  Object Snap on (see chapter 2, fig. 11). The result should 
look like in Fig. 17.
To overlap  the  profiles  click  the  button  for  the  preferred  overlapping 
ratio:  49th to  clear  overlapping,  50th to  make 1,5x overlapping,  51st to 
make 2x overlapping and 52nd to make 3x overlapping of the profiles. 



Note: since it is impossible to overlap sandwich panels, to prevent this  
error, application will not allow this procedure automatically.

Fig. 17. Façade with profiles installed

If  there  is  a  surface  with  equal  slopes  on  the  drawing  you can 
convert it into a plane by pressing the 4th button.

Chapter 4. Openings and division of the profiles

If there are openings in the drawing (e.g. doors, windows) they can 
be  cut  out.  Note:  Only  objects  full  width  intersecting  with  opening 
contour will be divided automatically.  To do this click 5th button, select 
the contour that needs to be cut out and click Enter. The profiles will be 
rearranged immediately.

If the profile has to be divided, a polyline boundary edge must be 
in a drawing. To draw a boundary edge select Draw → Polyline. Once a 
boundary line is drawn click 6th button. The program now requires you to 
select an opening (dividing) contour. Select the polyline and press Enter. 
Now objects that have to be divided must be defined. Select all profiles 
you  want  to  divide  and  press  Enter.  The  profiles  are  now  divided 
depending to your boundary line.

If there is a need to leave a gap between profiles when dividing, 
click the 7th button. It acts the same as the 6th button, except for after 
selecting boundary line and profiles to be divided, it asks to specify the 
gap between the sheets that are being divided.



If you want to divide profiles using axes as bounds, click the 8th 

button, select the façade contour, press Enter, select the axes that have to 
be converted to dividing boundary lines, press Enter. Now that the axes 
are  converted  into  boundary  lines  it  is  possible  to  divide  profiles  as 
described in the two paragraphs above.

The result of dividing profiles is presented in Fig. 18.

Fig. 18. Drawing of a façade after division

Chapter 5. Adding supports

To add supports the axes of the façade have to be drawn all across 
façade. If the axes are shorter they can be lengthened using 8th button as 
described in the last paragraph of chapter 4. To add supports click on the 
9th or 23rd button (they act the same). The program will ask to select axis. 
Once   the  axis  have  been  selected  press  Enter.  Define  the  width  of 
support and press Enter. 

To make a support B/2+B/2 click the 24th button, select axis and 
press  Enter. Select a continuous profile that is divided by the axis and 
press Enter.

To create a continuous support click the 25th button, select axis and 
press  Enter. Select the two profiles that have to be appended and press 
Enter.

To add a B/2+0,1L support click the 26th button, select axis then 
select  the nearest  axis to the right.  Select  the profiles that  have to be 
divided.



To make a 0,1L+B/2 support click the 27th button, select axis then 
select  the  nearest  axis  to  the  left.  Select  the  profiles  that  have  to  be 
divided.

To create a 0,1L+0,1L support click the 28th button, select axis then 
select  the  nearest  axis  to  the  left,  select  the  nearest  axis  to  the  right. 
Select the profiles that have to be divided.

To create a 0,1L+0,2L support click the 29th button, select axis then 
select  the  nearest  axis  to  the  left,  select  the  nearest  axis  to  the  right. 
Select the profiles that have to be divided.

To create a 0,2L+0,1L support click the 30th button, select axis then 
select  the  nearest  axis  to  the  left,  select  the  nearest  axis  to  the  right. 
Select the profiles that have to be divided.

Fig. 19 shows a façade with supports.

Fig. 19. Façade with supports

Chapter 6. Final adjustments

Settings of each profile can be changed. Clicking the 31st button 
allows  to  change  every  separate  profiles  color  choosing  from  RAL 
palette, true colors, or indexed colors. Pick the needed color, click  OK. 
Select the profiles and press Enter.

If  the  thickness  of  a  profile  needs  to  be  changed  click  the  32nd 

button, select the profiles and press Enter. Enter new thickness and press 
Enter.



33rd button  matches  the  properties  of  profiles.  Click  this  button, 
click on a profile that will be the source of properties, click the profiles 
that need to have the same properties.

If you need to lengthen any profile, this is done by 34th and 35th 

buttons, depending whether you have to lengthen: the beginning or the 
end of profile. If the profile is placed horizontally, the start of the profile 
is on the left, and the end is on the right. If the profile is placed vertically, 
the start of the profile is the lower side, and the end is the upper. Click 
the button, select the profile you need to lengthen and press Enter. Define 
the lengthening value and press Enter. If you need to shorten the profile, 
enter a negative lengthening value.

Chapter 7. Labels

Once the profiles are positioned correctly on the drawing, the labels 
need  to  be  applied.  The  application  stores  the  information  about  the 
selected profiles, so it can be done automatically. 

To turn the labeling on/off, use 14th or 36th button. They act the 
same.

When the labeling is turned on, you can adjust the position of it by 
clicking 37th button and the profile, that’s label needs to be placed higher, 
or 38th button and the profile, that’s label needs to be placed lower. Finish 
the command by pressing Enter.

By default labels in the drawing are presented as in fig. 20.

Fig. 20. Default presenting of the labels in the drawing



The default label includes (starting with the first line):
• Slope  against  profile  (on/off  using  43rd button  and  selecting 

profiles);
• Slope  along  profile  (on/off  using  44th button  and  selecting 

profiles);
• Profile thickness (on/off using 42nd button and selecting profiles);
• Profile color (on/off using 41st button and selecting profiles);
• Profile length (on/off using 40th button and selecting profiles);
• Profile number (on/off using 39th button and selecting profiles);
• Show overlap (on/off using 45th button and selecting profiles).

Command is finished by pressing Enter.
Profile  number  is  generated  automatically.  The  numbering  is 

generated decreasingly by profile length and other differing parameters 
(e.g. color). Profiles that have all properties matching will be given the 
same number. Since the quantity of some profiles change when making 
openings,  or  divisions,  profile  numbering  must  be  done  after  every 
change.

To show/hide construction line click 46th button, select objects and 
press Enter.

To set an automatic grouping line click 47th button, select one of 
the objects of the group of objects you need to group and press Enter.

To manually set the grouping line click the 48th button click on any 
of the objects that are to be grouped, click on the lower left corner of the 
profiles to be grouped then click on the upper right corner.

To renumber the profiles click the 12th button.
To get information about a profile click the 13th button and then 

click on the profile.
To  remove  everything  that  Fast  Specificator  has  done  to  the 

drawing click the 15th button.



Chapter 8. Setting page layout and generating specification 
tables

The management of page layout is automatic as well as the choice 
of the drawing scale.

Before setting up the frame for the drawing ORTHO function must 
be turned OFF (Fig. 21).

Fig. 21 Setting ORTHO off

Choose the page size from the four available presets: A4 (17th or 
59th button), A3 (60th button), A2 (61st button), A1 (62nd button). Click on 
the upper left corner of the drawing then click on the lower right corner 
of  the  drawing  (Fig.  22),  or  alternatively  press  Enter.  If  you pressed 
Enter instead  of  defining  the  bounds  the  frame  will  be  added  with 
drawing scale set to 1:100.

Fig. 22. Selection of frame area

The  frame  is  now  set.  There  are  two  ways  of  editing  the 
information fields in the lower right side of the frame. You can change 
the text by double-clicking it on the drawing frame, or by pressing the 



16th button. This calls up a text editor where you can edit the information, 
as mentioned in chapter 3.

To create a general specification table click on a new frame button 
(59th-62nd), press Enter for scale 1:100 and place the new frame near the 
original drawing. Turn the Object Snap ON (Fig. 21). Press 18th or 53rd 

button (they are the same). Click on the upper left corner of the inner 
frame of newly created frame (Fig. 23).

Fig. 23. Generating the specification table

Window of attribute editing pops up (Fig. 24).

Fig. 24. Edit Attributes window



Enter the name and date of the specification and click OK. 
It  is  also  possible  to  make  a  specification  for  elements  using 

specific  criteria.  The  54th button  allows  specification  generating  for 
selected areas. The sequence of making this specification is similar to the 
general  specification,  except after  clicking the 54th button you have to 
select the profiles that have to be included in the specification.

If a specification for a particular color profiles is needed, click the 
55th button, select  a profile that has the color needed for specification, 
and follow the steps of the general specification.

If a specification for a particular thickness profiles is needed, click 
the  56th button,  select  a  profile  that  has  the  thickness  needed  for 
specification, and follow the steps of the general specification.

The  legend  of  profiles  used  in  the  object  can  be  created 
automatically. Press 20th or 57th button (they are the same). Place the new 
sheet anywhere near the original drawing using your mouse.

If you notice that the drawing is too complex and the label of a 
certain profile is hard to read, it is possible to make an external cladding 
label. Click the 58th button, click on a profile and click on a place, where 
the label should be exported to (Fig. 25). Note: Due to the fact that this  
label is created as dimension object in AutoCAD, it is possible that it will  
be too small to read in some versions of the drawings. Increasing the  
dimension scale should fix the problem. (e.g. in the command window 
enter “dimscale” press Enter, enter number 1000 and press Enter again.

Fig. 25. External cladding label

To export the specification, click the 19th button. A new text editor 
window should pop up.  Select all text in the editor (shortcut  Ctrl+A). 
Access your preferred spreadsheet application (e.g. Microsoft Office or  
OpenOffice Calc) and paste the data (shortcut Ctrl+V).
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